Remote Mikrotik dengan Noip.com - Deep Insight News, History, Science and Technology

Breaking

Wednesday, 16 September 2015

Remote Mikrotik dengan Noip.com

Magzly.com - Seorang administrasi jaringan pada perusahaan setiap hari diharuskan mengecek dan maintenance jaringan. Ini diperlukan agar koneksi jaringan baik dan semua resource yang ada bisa berjalan dengan lancar. Internet saat ini bagi organisasi atau perusahaan sudah seperti jantung yang mendenyutkan setiap aktivitas diperusahaan.

Seperti ditempat saya bekerja pernah kejadian internet mati sekitar dua jam, karena ISP nya lagi trouble, itu hampir 70 persen aktivitas pekerjaan tidak berjalan. Dengan begitu pentingnya koneksi internet, maka wajar manajemen perusahaan tidak mau koneksi internet terputus, apalagi kalau putusnya karena trouble pada sektor internal. Maksudnya sektor internal adalah trouble yang disebakan kerusakan router, swicth, kabel jaringan, dan lainnya yang bukan berasal dari ISP.

Berdasarkan itu, sebagai seorang administrasi yang diberi tugas untuk mengurus jaringan internet di kantor, sudah kewajiban kita untuk melakukan check tiap hari, dan maintenance kalau ada yang rusak. Ada sebuah tagline yang disematkan kepada administrator jaringan yakni "Bagaimanapun caranya, down time harus sekecil mungkin".

Terus kalau kerusakannya parah, atau kantornya mempunyai banyak cabang gimana boss??? Bagi perusahaan yang memiliki kantor cabang cukup banyak, sebenarnya banyak yang bisa dilakukan, salah satunya adalah dengan melakukan remote client. Banyak jenis remote client yang bisa dilakukan, tapi kali ini sesuai dengan judul diatas kita akan membahas cara remote router mikrotik dengan Noip.com.

Cara ini ditujukan bagi koneksi internet yang menggunakan IP publik yang bersifat dynamic tidak statik. Artinya IP publiknya secara periodik akan selalu berganti secara terus menerus, sehingga tidak bisa dijadikan patokan lansung untuk melakukan remote router. Itulah sebanya kita menggunakan Noip.com, karene Noip.com merupakan salah satu situs yang menyediakan DDNS. Nah sekarang apalagi tuh DDNS? DDNS adalah singkatan dari Dynamic Domain Name Server yang merupakan service dari pihak ketiga berupa hostname.

Pirnsip kerjanya, DDNS menandai IP address suatu server kemudian merubahnya menjadi sebuah domain yang mudah diingat. Jadi berapa kalipun IP publik ISP berubah, domain namenya tidak akan berubah. DDNS ada yang gratisan ada juga yang berbayar (premium), kalau yang premium biasanya service yang diberikan full sedangkan yang free biasanya service terbatas. Khusus Noip.com kelebihannya menyediakan Dynamic Update Clients (DUC) dimana service ini berfungsi untuk mengeceken setiap perubahan IP secara continiu dan langsung diupdate keakun yang telah didaftarkan.

So, masalah IP publik yang selalu berubah-rubah sudah dapat diatasi. Cara membuat hostname di Noip.com akan dibahas dalam artikel lainnya. Sekarang sesuai judul kita akan membahas cara remote mikrotik router dengan hostname dari  Noip.com. Check this out,..

1. Masuk ke mikrotik router dengan winbox >klik system >Scheduler >Name (terserah anda) - kemudian pada on event masukan script dibawah ini :

# No-IP automatic Dynamic DNS update
#--------------- Change Values in this section to match your setup ------------------
# No-IP User account info
 :local noipuser "your_no-ip_user"
 :local noippass "your_no-ip_pass"
# Set the hostname or label of network to be updated.
 # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
 # To specify multiple hosts, separate them with commas.
 :local noiphost "hostname.no-ip.net"
# Change to the name of interface that gets the dynamic IP address
 :local inetinterface "your_external_interface"
#------------------------------------------------------------------------------------
 # No more changes need
:global previousIP
:if ([/interface get $inetinterface value-name=running]) do={
 # Get the current IP on the interface
 :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]
# Strip the net mask off the IP address
 :for i from=( [:len $currentIP] - 1) to=0 do={
 :if ( [:pick $currentIP $i] = "/") do={
 :set currentIP [:pick $currentIP 0 $i]
 }
 }
:if ($currentIP != $previousIP) do={
 :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
 :set previousIP $currentIP
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
 :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
 :local noiphostarray
 :set noiphostarray [:toarray $noiphost]
 :foreach host in=$noiphostarray do={
 :log info "No-IP: Sending update for $host"
 /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
 :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
 }
 }  else={
 :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
 }
 } else={
 :log info "No-IP: $inetinterface is not currently running, so therefore will not update."

Dari script diatas ada beberapa hal yang perlu diperhatikan dan disesuaikan dengan hostname yang telah dibuat pada Noip.com, baik user dan paswordnya serta dari ISP yang memberikan IP publiknya. Berikut script yang perlu anda isi dan sesuaikan.

:local noipuser "your_no-ip_user"
:local noippass "your_no-ip_pass"
:local noiphost "hostname.no-ip.net"
:local inetinterface "your_external_interface"




1 comment:


  1. Nice info gan
    sekedar share, saya pun menulis artikel tentang Remote Mikrotik dari internet
    namun cara yang saya terapkan yaitu dengan menggunakan VPN Client
    sehingga Mikrotik bisa diakses dibelakang Router yang memiliki Ip publik (dynamin dan static)
    https://catatan-lamers.blogspot.co.id/2016/06/cara-mudah-mengkakses-mikrotik.html
    Thanks :D

    ReplyDelete