Blok Torrent dengan Mikrotik 1 - Deep Insight News, History, Science and Technology

Breaking

Sunday, 13 September 2015

Blok Torrent dengan Mikrotik 1

Magzly.com - Torrent adalah sebuah sebuah technologi sharing data dalam suatu jaringan internet dengan konsep peer to peer. Ketika suatu file bereksistensi torrent di distribusikan ke internet, maka beban server akan lebih ringan. 

Kenapa beban server lebih ringan? Sebab ketika ada user yang mendownload file tersebut, mereka juga ikut mendistribusikannya kepada user baru yang juga lagi download. Begitu seterusnya user yang baru tadi juga akan mendistribusikan ke user yang lainnya.

Pada torrent ada istilah seeder, yakni orang yang memiliki data lengkap sebuah file torrent, atau orang yang sudah mendownload full file tersebut. Ini terjadi secara otomatis setelah user menyelesaikan proses download. Semakian banyak seedernya, speed downloadnya pun akan jadi tinggi, dan proses downloadnya akan semakin cepat.

Nah proses download dan seeding pada torrent inilah yang dapat menghabiskan quota bandwith internet di kantor. Apalagi kalau quota internet di kantor kita pas-pasan, siap-siap saja menghadapai kelemotan akses internet yang luar biasa. Lalu ekstension staf IT akan berdering tak henti-hentinya.

Pada mikrotik ada beberapa cara untuk block torrent, diantaranya dengan memanfaat kan rule pada layer7 protocols serta rule langsung pada firewall mikrotik. Pada pembahasan kali ini akan dibahas cara download torrent dengan menfaatkan rule firewall mikrotik. Sedangkan untuk layer7 protocols akan dibahas lain kali, oke check it out.

Copy dan paste-kan script dibawah ini pada terminal mikrotik, sesuaikan IP address yang menjadi sourcenya dengan jaringan anda. Saya menggunakan IP addres 192.168.0.0/24.

/ip firewall filter>
add chain=forward src-address=192.168.0.0/24 layer7-protocol=torrentsites action=drop
comment=torrentsites
add chain=forward src-address=192.168.0.0/24 protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS
add chain=forward src-address=192.168.0.0/24 content=torrent action=drop comment=keyword_drop
add chain=forward src-address=192.168.0.0/24 content=tracker action=drop comment=trackers_drop
add chain=forward src-address=192.168.0.0/24 content=getpeers action=drop comment=get_peers_drop
add chain=forward src-address=192.168.0.0/24 content=info_hash action=drop comment=info_hash_drop
add chain=forward src-address=192.168.0.0/24 content=announce_peers action=drop comment=announce_peers_drop
add chain=forward src-address=192.168.0.0/24 p2p=all-p2p action=drop comment=p2p_drop

Setelah itu tampilan pada firewallnya akan terlihat seperti berikut. Selamat mencoba, dan jangan pernah berhenti untuk terus belajar. Salam superrr.

No comments:

Post a comment