Limit Bandwith Sama Rata dengan Queue Tree 1 - Deep Insight News, History, Science and Technology

Breaking

Thursday, 14 November 2013

Limit Bandwith Sama Rata dengan Queue Tree 1

Magzly.com - Mikrotik Router menawarkan banyak sekali fitur untuk memanajemen bandwith. Salah satunya adalah fitur Queue Tree. Hampir sama dengan Simple Queues sebagaimana yang telah kita bahas pada topik sebelumnya, Mangle juga berfungsi untuk membatasi bandwith internet yang akan diberikan pada client. 

Perbedaanya adalah, kalau memakai Simple Queues, kita memasukkan nilai maksimal limit bandwith untuk download dan upload. Sehingga akses client tidak akan bisa lebih dari quota yang di berikan padanya walaupun, saat itu tidak banyak yang mengakses internet.     

Sedangkan dengan menggunakan Queue Tree, pembagian bandwith akan menjadi lebih dinamis. Karena, client bisa memakai bandwith secara maksimal. Artinya saat hanya satu orang saja yang melakukan akses internet, maka seluruh quota bandwith bisa dipakai semuanya oleh yang bersangkutan. Kalau seandainya hanya dua orang, maka bandwith akan dibagi dua, begitu seterusnya. Jadi pembagian bandwith untuk client lebih efektif dan efisien. 

Yang perlu diingat untuk melimit bandwith dengan Queue Tree, perlu dibuat sebuah rule Mangle. Dimana rule ini nantinya yang akan berfungsi untuk menandai aliran paket yang akan dilewatkan. Berikut scriptnya, yang saya dapat dari indonesianbacktrack, dan telah cukup sukses dibuktikan. 

Contoh ini digunakan untuk tiga client, dengan bandwith max 192 kbps. Saat ketiga client melakukan akses internet, masing-masing akan mendapat limit bandwith 64 kbps. Copy kan script dibawah ini lewat terminal pada mikrotik, tapi perhatikan bandwith internet anda, IP addres dan jumlah clientnya.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
/ip firewall mangle add \
src-address=192.168.11.2 action=mark-connection \
new-connection-mark=mark-ip2 chain=prerouting

/ip firewall mangle add \
connection-mark=mark-ip2 action=mark-packet \
new-packet-mark=ip2 chain=prerouting

/queue tree add name=ip2-downlink \
parent=local11 limit-at=96000 packet-mark=ip2 \
max-limit=192000

/queue tree add name=ip2-uplink \
parent=public limit-at=32000 packet-mark=ip2 \
max-limit=64000


/ip firewall mangle add \
src-address=192.168.11.3 action=mark-connection \
new-connection-mark=mark-ip3 chain=prerouting

/ip firewall mangle add \
connection-mark=mark-ip3 action=mark-packet \
new-packet-mark=ip3 chain=prerouting

/queue tree add name=ip3-downlink \
parent=local11 limit-at=96000 packet-mark=ip3 \
max-limit=192000

/queue tree add name=ip3-uplink \
parent=public limit-at=32000 packet-mark=ip3 \
max-limit=64000


/ip firewall mangle add \
src-address=192.168.11.4 action=mark-connection \
new-connection-mark=mark-ip4 chain=prerouting

/ip firewall mangle add \
connection-mark=mark-ip4 action=mark-packet \
new-packet-mark=ip4 chain=prerouting

/queue tree add name=ip4-downlink \
parent=local11 limit-at=96000 packet-mark=ip4 \
max-limit=192000

/queue tree add name=ip4-uplink \
parent=public limit-at=32000 packet-mark=ip4 \
max-limit=64000

2 comments: